1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sierra MC8775

Discussion in 'Ajutor: Comunicații' started by Marius '95, Aug 2, 2012.

  1. Marius '95

    Marius '95 Membru Senior

    Tocmai am instalat acest adaptor WWAN in laptop.
    - Prima surpriza neplacuta a fost ca n-are mufa pentru a doua antena. Traseele sunt la locul lor, doar mufa lipseste. Unde gasesc o mufa din aia microscopica sa o lipesc acolo?
    - A doua surpriza neplacuta a fost ca nu-i pe whitelist-ul din BIOS. Ghinionul lor, au dat peste un utilizator descurcaret. Am hacuit si dezactivat complet whitelist-ul.
    - A treia surpriza neplacuta a fost ca butonul hardware "Radio off" nu activeaza adaptorul WWAN daca cel WLAN este activat in BIOS. Practic, daca WLAN este activat in BIOS, n-am nici o metoda de a activa si WWAN. S-ar putea sa fie hack-ul de mai sus de vina. Mai testez, dar as aprecia niste explicatii despre cum ar trebui sa functioneze butonul - trebuie sa le activeze/dezactiveze pe ambele simultan? Combinatia Fn+F5 (Radio) de pe tastatura activeaza/dezactiveaza doar Bluetooth-ul.
    - A treia surpriza neplacuta este ca driverul instaleaza nu doar un modem, ci si vreo 4 porturi seriale, un adaptor WLAN, un device USB (?!?) ... adica horror! Intrebare pentru cei care au mai folosit asa ceva: CUM NAIBA SCAP DE TOATE ALEA!? Eu vreau doar un modem!

    Multumesc in avans celor care se deranjeaza sa raspunda fara sa ma intrebe "de ce".
     
  2. Neo

    Neo Motan agresif

    Um, am și eu un Sierra smth ca modem și tot așa instalează gârlă de chestii. Fără ele nu mere :biggrin: Cel mai probabil al doilea port este cel pentru GPS (?), dacă nu ai GPS built-in nici nu are rost să ai mufa respectivă. Din experiență îți spun că este 99% imposibil să o lipești cu scule de-acasă, este pur și simplu mult prea fină.

    Edit: pic attached. Nu deranjează cu nimic, apropos. Doar... sunt acolo :biggrin:

    LLE: dacă nu ai din bios selectare separată pentru ce face butonul hardware, și nu poți activa decât WLAN și WWAN, deal with it. Aia este, n-ai ce-i face. Nu prea pricep care-i faza cu whitelist, nu îl activează sau cum?
     

    Attached Files:

  3. miahi

    miahi Wizzard

    Am avut și eu ceva asemănător, acum e la Neo, dacă nu a scăpat încă de el. Poți să dai disable la unele din device-urile inutile (unul din COM-uri e pentru debug, există niște aplicații complexe care se pot lega pe-acolo să-ți dea tone de date despre conexiuni, alt COM e pentru GPS, altul e COM-ul de modem pentru comenzi AT). De scos de tot e mai complicat, din câte îmi aduc aminte se "prezintă" sistemului ca un adaptor USB cu funcțiile pe care le-ai enumerat tu. Probabil un hack de firmware ajută, vezi că tool-urile de care ziceam mai devreme se ocupă și de firmware dump and stuff.

    Mufe de genul ăla găsești în routere wifi sau adaptoare wifi (chiar și de-astea mici USB). Faptul că nu se vede nici o mufă pe afară nu înseamnă că nu are. Eu am avut o placă cu vreo 3 mufe de-astea, dar săptămâna trecută am dus-o la reciclat :frown:. Faptul că există trasee pentru o a doua mufă nu înseamnă că o să o folosească dacă legi ceva acolo.
     
  4. Neo

    Neo Motan agresif

    Ăla este, dar la mine nu merge dacă nu are toate chestiile alea instalate :S
     
  5. miahi

    miahi Wizzard

    Eu îmi aduc aminte că dacă dădeam disable la una din chestii (nu portul NMEA) nu mai mergea GPS-ul, dar nu mai țin minte ce :smile:. La cel pe care-l am acum (Gobi 2000) se întâmplă asta dacă dau disable la un wifi adapter (?!) pe care-l instalează.

    BTW, știe cineva unde găsesc un modem intern de 21Mbit?
     
  6. Marius '95

    Marius '95 Membru Senior

    Multa lume pe internet se plange de aceesi problema si multi dintre ei au modemurile originale, deci nu patch-ul whitelist-ului este problema.

    Am facut un upgrade de firmware la modem care n-a rezolvat problema, dar cica l-a upgradat la 7.2 Mbps. :what: Apoi m-am apucat de testat driveri. Cei generici de la Sierra au trebuit putin "convinsi" sa se instaleze. Apoi m-am apucat de dezinstalat si permutat porturi, ca aveam 14! Si la un moment dat a inceput sa mearga. Nu stiu exact care a fost setarea reparatoare.
    Acum merge cu toate alea activate. Mi-e si frica sa intru in BIOS; poate il stric.

    Butonul hardware inchide radio la WLAN si deconecteaza complet WWAN si BT - adica nu mai apar in Device Manager. Combinatia Fn+F5 comuta intre BT, WWAN, ambele, respectiv nici una. Tot deconectandu-le. Mai exista "Airplane Mode" in aplicatiile de monitorizare care doar dezactiveaza partea radio de la WWAN, la BT LED-ul nu se stinge, deci probabil nu raspunde la comanda din software.

    Daca vreunii dintre voi mai aveti modemul asta (sau echivalent), puteti sa-mi spuneti cat consuma in diversele moduri (transfer activ, conectat la retea dar idle, neconectat cu radio on, radio off, deconectat cu Fn, deconectat din buton, dezactivat din BIOS)?
     
  7. miahi

    miahi Wizzard

    Din specificații ar trebui să consume maxim 800mA, și se alimentează la 3.3V => cam 2.5W max. Puterea depinde de emisie în principal, iar asta depinde de cât de departe ești de celulă.
     
  8. Marius '95

    Marius '95 Membru Senior

    Am pus scoci pe contactul 20, cel care se ocupa de dezactivarea placii, si acum Windows-ul vede placa, dar BIOS-ul nu trece de POST daca butonul radio nu-i pe ON. Mai mult, daca cumva dezactivez placa din BIOS, se blocheaza complet, trebuie resetat CMOS-ul.
    Sa imi pice dintii daca mai cumpar vreodata laptop Lenovo!

    Care are un programator de flash-uri. Vreau sa-mi pun CoreBoot. Un linux nu poate fi mai prost decat jegul de Phoenix pe care il am acum, nu?!
     
  9. Neo

    Neo Motan agresif

    Lol.